開始使用更新的 Eclipse 後,發現老是會出現 serialVersionUID 的 warring,由 warring 的內容來看他跟 seriable 有關,只是以前怎麼好像沒遇過,查了一下才發現。

原來是不同的 JVM 的 serialize 實作不必然相同,所以這個 serialVersionUID 真的就是 serail Version 的 UID,可以用來表明 serialize 的版本,如果你將一個 instance serialize 後,在 deserialize 時就會檢查 serialVersionUID 是不是一樣,不一樣的話就不會 deserialize,就能控制相容性的問題。
如果你沒有自己定義 serialVersionUID 的話,JVM(?) 會依據 class 計算出不一樣的serialVersionUID,下次你在 class 裡新增 member 的話,serialVersionUID 不一樣就不能做
deserialize 。
如果你自訂 serialVersionUID,就能控制 serialVersionUID,class 能相容從舊的 serialize storage 再deserialize,而新增的 member 就會變初始預設值。在 runtime 時可由 java.io.ObjectStreamClass取得 serialVersionUID 值。
如果不知道取什麼值 JDK 有個 tool
serialver.exe 可以幫你產生值。


serialVersionUID 用來表明類的不同版本間的兼容性。如果你修改了此類, 要修改此值。否則以前用老版本的類序列化的類恢複時會出錯。
  
在JDK中,可以利用JDK的bin目錄下的serialver.exe工具產生這個serialVersionUID,對於Test.class,執行命令:serialver Test。

為了在反序列化時,確保類版本的兼容性,最好在每個要序列化的類中加入 private static final long serialVersionUID 這個屬性,具體數值自己定義。這樣,即使某個類在與之對應的對象已經序列化出去後做了修改,該對象依然可以被正確反序列化。否則,如果不顯式定義該屬性,這個屬性值將由JVM根據類的相關信息計算,而修改後的類的計算結果與修改前的類的計算結果往往不同,從而造成對象的反序列化因為類版本不兼容而失敗。

不顯示定義這個屬性值的另一個壞處是,不利於程序在不同的 JVM 之間的移植。因為不同的編譯器實現該屬性值的計算策略可能不同,從而造成雖然類沒有改變,但是因為 JVM 不同,出現因類版本不兼容而無法正確反序列化的現象出現。

當我們的系統不太經常需要序列化類時,可以去掉這些警告,做如下設置:Window-->Preferences-->Java,將 serializable class without serialVersionUID 的設置由 warning 改為 Ignore。然後Eclipse會重新編譯程序,那些警告信息也就消失了。

最後的建議是,如果我們開發大量需要序列化的類的時候,我們最好還是還原為原來的設置

台南小新 發表在 痞客邦 PIXNET 留言(0) 人氣()