adt-bundle-windows-x86_64-20131030 用來開發 Android 4.0 以上的專案都沒啥問題,今天我拿書籍的範例光碟來編譯,卻出現 "Unable to Execute Dex: java.nio.BufferOverflowException" 的錯誤訊息。google 半天的結果,原來是內建的 Android SDK Build-tools (19) 有問題,只要換成新版的 19.0.1 或降版成 18.1.1 就 OK 了。

  1. 執行 Android SDK Manager
  2. 勾選 Tool → Android SDK Build-tools (19.0.1)
  3. 勾選 Tool → Android SDK Build-tools (19)
  4. 按下 Install packages... 執行安裝
  5. 按下 Delete packages... 執行卸載

台南小新 發表在 痞客邦 PIXNET 留言(0) 人氣()